PrestaImport, PrestaShop 8 y PHP 8

1472 lecturas
2023-04-14
Sobre la compatibilidad de PrestaImport con el nuevo PrestaShop 8 y con PHP 8.
Imagen de PrestaImport, PrestaShop 8...

Seguramente ya sepas que está a la vuelta de la esquina el nuevo PrestaShop 8. De hecho, la versión 8.0.2 ya se considera stable, aunque no ha tardado mucho en aparecer la 8.0.3, esto indica que aún hay cosillas... Nosotros no vamos a ser como algunos bloggers que te animan a actualizar YA y sin ninguna duda ni temor. Como tú, para una tienda en funcionamiento sabemos la problemática que conlleva. No obstante, para una tienda nueva PrestaShop 8 ya sí es una opción.

PrestaShop salta de la rama 1.7 a la versión 8

¡Menudo salto! Pero no te emociones (ni te preocupes) en exceso. Realmente el número 8 obedece, sobretodo, a una decisión comercial, y refleja el cambio de propietario de PrestaShop.

Pero vamos al grano: ¿es PrestaImport compatible con PrestaShop 8? La respuesta es muy simple: . Como siempre, estamos pendientes de las nuevas versiones, y vamos testeando y adaptando nuestra herramienta, y ya ha sido confirmada su compatibilidad, sobre PrestaShop 8.0.3, y seguiremos haciéndolo para las futuras subversiones.

Y, como la cosa va de ochos, un tema a tener en cuenta es la versión de PHP (el lenguaje de programación del lado del servidor con el que funciona PrestaShop). Desde PrestaShop confirman que su versión 8 es compatible con PHP 8.1, aunque la rama más alta actual de PHP es la 8.2, pero seguirán avanzando. En el caso de PrestaImport, la compatibilidad es exactamente la misma: hasta PHP 8.1.

Entonces, recuerda, si montas ya una tienda con PrestaShop 8, lo recomendable es que uses PHP 8.1, pero si tienes aún un PrestaShop 1.7 la versión recomendable de PHP será una 7.x, la rama más alta 7.4 no estaría mal. Y para los que aún se mueven en PrestaShop 1.6 la versión recomendable de PHP sería la 7.1

Para terminar, un apunte: PrestaImport mantiene su compatibilidad con versiones pasadas de PrestaShop, por supuesto 1.6 y 1.7, pero también incluso 1.4 y 1.5.

Espero que te haya servido de utilidad.

Noticia siguiente: No hay

Noticia anterior: Actualizar PrestaShop VS Actualizar PrestaImport